This allows you to burn-in selected items of camera metadata into the visible area of each video frame with frame accuracy.

 

Example metadata burned-in

Example metadata burned-in

 

Note that if you simply want to time-stamp your files then use the Burn-In Time Stamp tool instead.

 

The metadata items are:

 

Timecode
User Bits
Time of Recording
Date of Recording
Shutter speed
Aperture (f-stop)
Exposure Mode
Gain in dB
Focus Distance in metres
Focus Mode
White Balance
Image stabilizer on/off
Audio details (DV file types only)

 

Also for files from AVCHD, Contour and some other cameras that have a built-in GPS unit, the following Geotagging metadata items are available:

 

Latitude
Longitude
Altitude
Speed
Track (direction of motion)

 

The Geotagging metadata items are usually also available when Sony AVCHD cameras are set to standard definition MPEG-2 PS mode. The format of the Geotagging items can be chosen by the Geotagging options in Tools > Options > General.

 

You can also burn-in a line of custom text which may contain a brief message or perhaps your own identifier used in your video project. The text can also contain a tag which will automatically be filled with the name or pathname of the video file.

 

The metadata text is written directly onto the image, but you can choose instead to have it written onto a solid rectangular black background which you may find easier to read, but will obscure more of the image.

 

You can choose the font, size and position of each item of metadata text; and choose a language and custom format for the recording date and time items - see Options - Burn-in for more details.

 

You can also specify an image file to be burnt-into the video. The image file may be PNG, BMP, JPG or GIF format. You may find this useful if you have a company logo that you want to have burnt-into the whole duration of the video file. If you have designed the image file with transparency, then it will be correctly anti-aliased with per-pixel transparency so that it has a pleasing natural appearance. You can also set the position, size and overall transparency of the image on the video frame.

 

The output file type can be chosen as AVI or WMV.

 

Also, in some versions of Windows you can choose MPG or MPG for DVD output type. These output types are only available in Windows Vista and Windows 7. They are also available in Windows 8 or 8.1 but only if you also have the optional Microsoft "Windows Media Center" feature pack installed - for more details see the following Microsoft web page (correct at the time of writing):

 

http://windows.microsoft.com/en-gb/windows-8/feature-packs

 

You can also choose to "burn-in" the metadata text on a transparent background instead of on the video frames by checking the Transparent background (alpha channel) option. This is usually faster than performing a burn-in onto video frames, and it may be useful in video editing programs which support alpha transparency, where a transparent-background burn-in file can be imported onto a separate layer which allows the text to appear across the video frames of other layers. See the Options - Burn-in Output section for more details of the transparent background option.

 

 

information

INFORMATION: If you do not want to wait for the whole of your video file to be burned-in, and you simply want a single still-frame image with burned-in metadata (perhaps to send as an email attachment or to include in a document), you should instead use File > Save Image or File > Copy Image to Clipboard - see Save Image and Copy Image to Clipboard for more details.

 

 

The operation of the burn-in tool is slightly different for DV AVI and DV MOV files, compared to other supported file types, so they are described separately below.

 

Burning-in DV AVI and DV MOV files

 

For DV AVI or DV MOV files, the burned-in output file is always of the same file type. The DV AVI or DV MOV files are the most convenient for working with DV footage, so these are the only output type supported for these input file types.

 

When you select Tools > Burn-in Time Stamp or Tools > Burn-In Metadata, a Confirm Settings dialog box appears where you can check and if necessary change any of the burn-in options. These are the same settings that appear in the Burn-In section of the Tools > Options menu. See Options -Burn-in for more details.

 

When you are satisfied that the settings are correct, click OK, and you are prompted for an Output File name. The default file name is the same as the input file except that "-burn" is appended to the part before the .avi or .mov extension (e.g. myfile-burn.avi or myfile-burn.mov).

 

DVMP Pro will then make an exact copy of the existing AVI or MOV file to the output file name, except that each frame of the output file will have the metadata values written across it.

 

Burning-in non-DV files

 

AVCHD MTS/M2TS, HDV M2T, MPEG-2 PS (Sony HDD/DVD or MOD), MOV or MP4 files almost always contain video that has been compressed with an "intra-frame" compression scheme which means that it does not make sense to treat them like DV AVI or DV MOV files. In most cases burning-in to the same compression scheme and file format as the input file would just waste processing time, especially when you may want to perform another subsequent stage of re-encoding in your video editing software. A lossless or light lossy compression scheme is better here.

 

Consequenty for these input file types, the burned-in output file can be an AVI file or a WMV file - you can choose which you require.

 

If you are using some versions of Windows (see earlier), you can also choose a MPG or MPG for DVD output file type.

 

The output file type is selected in Tools > Options > Burn-in > Output.

 

WMV is often most convenient for making burnt-in files which play well on a PC. However, AVI is more flexible, allowing you to choose from a wide range of compressors that are already present on your PC, and for maximum quality you can choose "Uncompressed" or a lossless compressor such as "Lagarith". Note that there is a different set of options associated with each of the output file types.

 

If you select WMV as the output file type, you can choose the Quality of the video frames - a higher quality setting will produce better-looking video but also a larger output file. There are also options to Deinterlace or Resize the video as it is compressed/encoded. The resizing option may be useful if you wish to make a standard definition (or even smaller) burned-in video for playing on your PC. You can also choose whether the input file's audio stream is included in the output file by checking Include audio stream in output WMV file - the WMV file will contain the audio as stereo PCM. If you uncheck this option the WMV file will contain only the burnt-in video without an audio stream (i.e. silent).

 

For more information about the WMV settings, see the WMV Output Settings section.

 

Instead of WMV you can select AVI as the burned-in ouput file type. The AVI file holds the frames separately using a lossless or lossy compression scheme. You can select the compression scheme by choosing an output AVI video compressor in the Tools > Options > Burn-in > Output menu. By default, "Uncompressed" is used but this uses a lot of disk space, so you are advised to select one of the compressors in the list by clicking the adjacent Select button.

 

The list of AVI video compressors that you are presented with is created by DVMP Pro which scans the system for existing video compressors that are already installed on your PC. It examines the capabilities of each compressor to see which are likely to be able to compress high resolution frames, and presents these as the list from which you can select your chosen compressor. Note that the amount of compression varies widely between different compressors - higher amounts of compression will usually produce poorer quality output.

 

Some compressors have a set of properties which can be adjusted (such as the amount of compression used). These affect the internal behavior of the compressors. You can examine or change these properties by clicking the Properties button next to the compressor's name. Some properties may adversely affect the operation of DVMP Pro so you are advised to avoid changing any properties if you are unsure what effect they will have.

 

You can also choose whether the input file's audio stream is included in the burned-in output file by checking Include audio stream in output AVI file. If you uncheck this option the AVI file will contain only the burnt-in video without an audio stream (i.e. silent).

 

For more information about how to select an AVI Video Compressor and examine its properties, see the AVI Output Settings page.

 

If you are using some specific versions of Windows you can select MPG or MPG for DVD as the burned-in output file type - both are MPEG-2 Program Stream files that have the video stream encoded as MPEG-2. MPG for DVD is similar to MPG except that it has certain internal constraints that make it more compatible with the DVD specification. These output types are only available if you are running Windows Vista or Windows 7. They are also available if you are running Windows 8 or 8.1 but only if you also have installed the optional Microsoft "Windows Media Center" feature pack which is obtainable from the following Microsoft web page:

 

http://windows.microsoft.com/en-gb/windows-8/feature-packs

 

If you are intending to use separate DVD authoring software to produce a playable DVD, then MPG for DVD may therefore be a better output file type to choose from, provided your DVD authoring software does not attempt to re-encode the burned-in files again. Unfortunately some DVD authoring software will always re-encode its input files to MPEG-2 even if they are already in DVD-compliant MPEG-2 format! With such software it wouldn't matter if you had chosen MPG for DVD or any other output file type - the software would still re-encode them to MPEG-2 again. In such cases it's likely to be quicker to choose AVI as the output type with a faster AVI video compressor. The only way to know if your DVD authoring software behaves like this is to import MPG for DVD file types into it and see whether it insists on re-encoding them when you tell it to "make" the DVD.

 

Please note that a currently selected video decoder (in the Tools > Options > Video Decoders menu) is used during the burning-in procedure to read the input file. For further details on selecting a video decoder, see the Options - Video Decoders section.

 

When you select Tools > Burn-in Time Stamp or Tools > Burn-In Metadata, a Confirm Settings dialog box appears where you can check and if necessary change any of the burn-in options. These are the same settings that appear in the Tools > Options > Burn-in menu. See the Options - Burn-in section for more details.

 

When you are satisfied that the settings are correct, click OK, and you are prompted for an Output File name. The default file name is the same as the input file except that "-burn" is appended to the part before the .avi or .wmv or .mpg extension (e.g. myfile-burn.avi).

 

DVMP Pro will then create the burned-in file. This process takes a lot longer than burning-in standard definition DV files - the amount of time will vary widely depending on which output file type is chosen, and (if AVI is chosen) on the selected output AVI video compressor.

 

Please note that although DVMP Pro sets the correct display aspect ratio in the burnt-in AVI files, some software ignores this and may incorrectly identify the display aspect ratio for some video resolutions. For example if your camera's recording resolution is 1440x1080 (non-square pixels) the burned-in AVI file may be interpreted incorrectly as 4:3 by video editing packages and other programs which will make it appear horizontally squeezed. In this case you may have to set the display aspect ratio manually to 16:9 within your editing program. The WMV and MPG file types are not affected by this problem.

 

See Also:

Options - Burn-in

Time Stamping Video

Burning-in Metadata

How Burn-in works